Alexa does not react to user input - capture block

Hello everyone,

I have a problem with alexa not reacting to the users input.

I am retrieving the possible user answer from a spread sheet and store it in a variable. Than I use the capture block to store the users answer into another variable. After this I used an if block to compare those two and than choose the correct path.
If have chosen this approach because you can not use variables in a choice block. At least it seemed not to work.

I tried it in the voiceflow simulator and in written form it works perfectly.
But after I uploaded everything, it does not work anymore. Even if the right word is captured.
The parts of the skill where I used a choice blocks (texts with no variables) works.

I would be very happy for some help.

Thank you so much.
Becky

1 Like

Hello again,

I tried to “fix” it using a choice block and just writing all possible answer into it. It still didn´t work.

Now I realised that also in my first choice block, just one answer possibility is working. For the other one simulator is catching the right answer but it always goes into “else”.

What am I doing wrong?

Please help.

Now it started to throw errors

"request": {
	"type": "SessionEndedRequest",
	"requestId": "amzn1.echo-api.request.c3f32c11-046b-4256-86a5-e462c6dc03b2",
	"timestamp": "2019-06-05T20:59:32Z",
	"locale": "de-DE",
	"reason": "ERROR",
	"error": {
		"type": "INVALID_RESPONSE",
		"message": "Invalid SSML Output Speech for requestId amzn1.echo-api.request.22395768-0313-4c30-bd69-dcbd0b3d5b0a. Error: Value '50mss' invalid on attribute time for element break"
	}

I just changed the possible answers.

your SSML seems including this, right?

<break time=“50mss”/>

It should be like this.

<break time=“50ms”/>

Anyway, could you give more info like screen captures or some example values? that might be helpful.

Hello Kun,

thanks so much. the mss issue already fixed the complete error.

I made a video about the initial problem: alexa does say, that she does not understand even after catching the right word.

I was quite nervous filming so please ignore the mmms :slight_smile:

Thank you so much.
Rebekka

Wow, captured using Youtube! Great!

Seems Capture Block doesn’t works because you choiced Custom slot type but gave no custom slot examples. As I know, custom slot type requires some examples to make Alexa easily understand and recognize what you said as a slot value.

How about put some phrases as custom slot examples?

Hello,

thanks for your reply.
First I thought it didn´t work… but it actually did. The first answers I tried have always been “ja” (yes) this didn´t work even if I had entered it as example into the capture block.
But I found out that this is actually the only answer that is not working. “Nein” (no) and all other words work.
So this is a big step THANK YOU :smiley:
Now I just need to find out why it is not working for yes.

Sorry fo the many answers…

Becky

No problem!

Anyway, I read your reply and checked your Video again. You seems to have two blocks which can get user saying “Yes”, right?

  1. captureUserChoices
  2. choice block in MENU

I guess if user says “Yes”, Alexa doesn’t understand which block user’s “Yes” is intended for, that’s why “yes” is not working, IMO.

I am completely unsure but how about remove “Yes” from choice block in MENU and change it a different phrase like “ready” or something?

Thanks again,

I am a bit afraid that I am making a dump mistake^^
To make it a bit easier for me to find the issue I build a very simple project. Where you just can answer “yes” or “no”.

Same problem. :frowning:

"request": {
	"type": "IntentRequest",
	"requestId": "amzn1.echo-api.request.9f5ff7c0-be59-4fa2-9679-770faf29f5fe",
	"timestamp": "2019-06-09T20:46:03Z",
	"locale": "de-DE",
	"intent": {
		"name": "capture_katze",
		"confirmationStatus": "NONE",
		"slots": {
			"capture_slot_oiqle": {
				"name": "capture_slot_oiqle",
				"value": "Ja",
				"resolutions": {
					"resolutionsPerAuthority": [
						{
							"authority": "amzn1.er-authority.echo-sdk.amzn1.ask.skill.2c89b39b-6216-474c-bd37-0e634f8dce8a.capture_slot_oiqle",
							"status": {
								"code": "ER_SUCCESS_MATCH"
							},
							"values": [
								{
									"value": {
										"name": "ja",
										"id": "a78c5bf69b40d464b954ef76815c6fa0"
									}
								}
							]
						}
					]
				},
				"confirmationStatus": "NONE",
				"source": "USER"
			}
		}
	}
}

}

You You made a test simply! That’s nice! :+1:
Capture block looks work correctly, then If block seems this problem.

Anyway, I created the same simple skill in Japanese, and it sometimes works and somtimes not. I’m lost…

But one thing to try:

When adding a condition In If Block, press </> and pull down to very bottom, you see “Advanced”, then you can type your condition sentence by keyboards. Then, type like this.

Notice: when you type variable name, type “{” first, then variable names show up, then select right one. Sometimes your own variables don’t show up, then type the first 1 or 2 letters, it will show up.

I don’t think if this is reason why yes doesn’t work, but for me, this works.

1 Like

Thank you so much! This seems to work! :smiley: