API Call not returning any value

@tiaguituh05 In case you’re getting the Invalid token response from the HTTPS API,
and you’re sure the device auth token is correct - it could be a GEO DNS issue.

1 Like

Hi @john93

Yes I’m sure the token is correct, as I can call the service via postman.
How do I overcome the GEO DNS issue?

I’ve tried to manually ping blynk.cloud server from my cmd, and use the ip adress on voiceflow, now I get a 500 - Internal error

Thank you,
Tiago Silva

show me the URL you’re using please ?

Hi, it is like the following:

https://blynk.cloud/external/api/update?token=xpto&v1=1

This one gives me the invalid token error.

Trying to replace by the IP address my computer resolves for the blynk.cloud DNS, gives me the 500 internal error

Both work on postman or browser.

Thank you

Due to current GeoDNS settings you need to put server address with suffix manually depending on your region:

https://fra1.blynk.cloud/ – Frankfurt
https://lon1.blynk.cloud/ – London
https://ny3.blynk.cloud/ – New York
https://sgp1.blynk.cloud/ – Singapore
https://blr1.blynk.cloud/ – Bangalore

The server region could be found in the bottom right corner of the web console ( blynk.cloud ).

1 Like

Holy moly, that was it!

Logged on into my blynk cloud account and indeed noticed it was in the london region on the bottom right.
Addind the lon1 prefix to the request solved it.

Can’t thank you enough @John93

1 Like

If you need any help, feel free to ask :slightly_smiling_face:

Have a great day.

1 Like

I was just following the conversation and was wondering: whose GeoDNS settings? Is it the servers (Blynk or Voiceflow?) or your own device when you send that request via your browser?

It’s blynk server address.