Cannot find skill is the response to everything!

Suddenly everything you say, my skill responds “cannot find skill.” It was working find when I certified… I tried recertifying, but Amazon, says this is still the case, which leads me to believe there might be a problem with Voiceflow…?

1 Like

Same here. Skill is certified, and tried on multilpe devices with the same issue “Cannot find skill”.

1 Like

Hey, was this resolved?

Hi Anna! Was this resolved?

Not for me. I did see some AWS reports on down detector so I’m not sure if it’s related to that.

Also, not sure if this helps but I updated my skill a few times today and the new changes aren’t being reflected.

Hi Braden,

I had to resubmit my skill and go through the certification process again. Once they republished my skill it was resolved.

Same thing happened with my already deployed Google skill today while alexa skill works fine. Not sure if its related but it started happening right after i submitted an update to the google skill. The new version is under review by google and the older one has stopped working (it says “cannot find this skill”)

Will report back if and when it gets resolved.

I suspect it has something to do with voiceflow itself since its happening with both Google and Alexa.

Would appreciate a response from Voiceflow here! Because if it turns out that this is in fact because of what i suspect (voiceflow has an OFF switch in all our DEPLOYED apps and they can turn it OFF when they like), i will reconsider using Voiceflow for any serious projects.

And the fact that there has been no response from them in over a month (since first post in this thread) is all the more reason to worry.

Hi Vinay, first off we did respond and no we do not have an off switch. That would not be fair for our users and we would never do something like that without advanced warning.

We have no reported downtime and you can check out our servers at:

In most cases this is Google or Alexa’s issue. The most common problem is people are invoking the wrong skill or Action because they have the wrong language setting enabled on their device. It is not uncommon for the platforms themselves to have outages completely unrelated to Voiceflow, such as this one:

Please email us at so that we can take a look, thanks.

Hey @Braden
I have to say - Holy Crabs - didn’t know about that outage.

Forgive me if my post sounded accusatory. I meant it to be investigatory. I really appreciate you reading this and investing your time here.

Back to the topic -
Yes, you did respond… BUT The OP resubmitted the app and the problem went away - but we didn’t find out what happened. No probing. I’m sure you guys have 100s of issues to deal with everyday, maybe it slipped through the cracks.

The most curious thing is

  • The OP gets an error on their ALEXA skill. “Cannot find this skill”.
  • I get the exact same error on a Google skill.
    That rules out this being a Google or Amazon error, right? That suggests the problem is somewhere in the voiceflow workflow/code. Does it not? Maybe I’m missing something.

Also - Google doesn’t use the word ‘Skill’ which is an Amazon Alexa terminology. They call it actions. Further reason to suspect the error message is not from the Google platform, but voiceflow.

And the fact that this happened to an already deployed app is further intriguing.

Your thoughts?

Interesting - can you email me the name of the project? We can take a deeper look.

Also, how long is that response taking? I wonder if it’s a time-out and that could be our default message for a time-out if your internet latency is too high etc.

It’s happening for all users. Not limited to my device or internet connection.

Error message occurs instantly. 1-2 seconds.

The latest update got approved and it started working. But I’m very curious to still understand what happened.

Project Name is Just Watch, my registered email address is

Btw, Facebook login is failing

Hi Vinay, I think Facebook Login is because you’re using the Brave Browser which we don’t support.

In terms of the issue you are facing, can you email me the issue so that I can introduce you to our Customer Support team? My email is

Thanks so much!