Can't add a new value to Airtable using POST request

Hi! I am having an issue while trying to make a simple Alexa skill that adds the user reply to a database. This is the error:

I cannot add more screenshots, but to summarize:

  • I already tried with a Choice block instead of a Capture one, configuring intent and entity, with the same result

  • If I go to the API block and send a test request, it works succesfully

  • If I connect the Choice/Capture block directly to the next block that says “Great! {fooddd} was added to your database”, it identifies my responses properly

So I’m lost, I am not getting why it’s not working.

Any help would be appreciated, thank you very much!!

I always move the data captured in my entity variables to a working variable I define separately. I base all my work with that data from this working variable. Not sure if this is necessary, but it works for me with my Airtable API queries, etc.

Thanks for the help!

I already managed to solve it, I hadn’t set the Content-type header:

I am newbie on this, hehe. I discovered the Debug mode and i could find that there was a problem with how i configured the API block :joy:

Anyway, many thanks for the quick response!! :two_hearts: