German text is spoken with english voice

Hi there,
I have a voiceflow with german text. Unfortunately the Action Console speaks with an english voice (and heavy english accent), although I think I have set the language to german everywhere…(Voiceflow, my Google account and of course in the Action Console). What could be the reason? Thanks for your help

This is something you can set during the first step of the creation of the project on the GOogle Action console. If you’re not to familiar with the Google Action Console or Dialogflow, the easiest way to get Google speak in the locale you want is to test it on a real device linked to your dev account,

FYI, these are my Japanese settings, which works.

  1. Voiceflow’s Build setting.

  1. AoG’s Overview and click on “Modify languages in Settings”. also make sure that only your language is selected at the left.

.

  1. Dialogflow’s settings.

  1. AoG’s test

This is my old project and I don’t remember how to set my language, but In AoG, you need to set your language by yourself, I mean “Upload to Google” might not set your language automatically.

Thank you guys for the profound help!
@Kun432 strangely I have all these settings right, but still I have the problem. I was hoping I was just overseeing one setting to do… I guess I retest it with a new test-project. Wish me luck! :wink:

Hey, it’s me again… I set up a new test project to make sure I set up ALL the settings to german. But still my device (also set to german) is talking the german text with english intonation. Anyone has an idea, where the problem might be?

Hello,
i have same issue. Did someone found a solution?

@BeeOne

are you using current integration with Dialogflow or new google integretion with Actions Builder?

if you use new one, it’s a bug and I’ve already reported it.

@kun432
thanks for the info
I have published it over cerator.actions.voice…

Thats bad, is there a workaround or something else to solve that?

This is just a workaround only for testing.

open your action on Actions on Google, click Develop tab, then click settings.

In “Google Assitant voice” in the middle, uncheck “Match user’s language setting”.

s_1208

You will see voice name changing to voice name with locale string. Maybe in your case, it should be “DE-DE”.

s_1209

Then click “save” in upper right.

s_1210

Now you can test with German voice.

However, after uploading from Voiceflow, it should turn back… So, basically, we should wait for voiceflow to fix this bug.

Also, in my end, I cannot upload from Voiceflow currently and it should be another bug. Remember that new google integration is a very new feature and still in progress. you may see other bugs, If you find bugs, you can report a bug from Intercom. That will improve Voiceflow!

@kun432 thats great it works on this way. Thanks a lot!
Thats enough to test and to present it to my client in german…cause the eng versin was a no go
hopefully voiceflow will fix this asap

another qustions
Do you know why google always starts the test version on my devices where i am logged in with the google account?

Generally, there are 2 versions in Google Actions:

  • test version
    • action which you are developping and not published in public. only developer can access.
  • production versioon
    • action which you have finished developping, submitted to Actions store, been certified by Google. all the people can access.

After published in Actions store, that message will gone for who enable your Action.

One more thing for developer. As developer, when adding new features but don’t wanna break productionn version, right? In that case, develop and test new features for test version, then published it as a new production version. Developer can change version in test settings.

This is a sample for my published action. (This is an old action and not developed by Voiceflow, it might be different.)

@kun432
Thats my problem the action is deployed.
Only on my devices with the G-account which i develop the action it starts always with the test version.
On other devices with other G-accounts it starts normal. But that’s just a minor thing.

I just make a new release withe new language setting to get the german version. hope this will work fine…

Thanks for your help!

now it has been fixed!