Permission Block not working

I’m not sure if I’m using the permission block correctly.

To my understanding the permission block is suppose to send the user a request to enable their email, phone, etc.

When testing the block on my Alexa device, the only thing that appears is a notifications that lets me know I have to enable permission. However, I still have to manually click over to the setting tab and enable email and stuff.

I’m not sure if this is what is expected from this block or not.
Thanks for the help!

It is expected, the Permission block (you also need Account Linking block first) is mainly to explicitly notify the user to enable permissions and to help users pass Alexa certification as this is a required step for certification (notifying users of Permissions).

1 Like

Thank you very much!