Skill works in Voiceflow but not Alexa (echo or ADC)

Hi so,

I’m when testing my skill in voiceflow it works fine but once I uploaded it to Alexa, I noticed now of my changes were uploaded. When I tried to invoke my skill I got a response “There was a problem with the requested skill’s response”, refer to screenshot below:

I’m getting close to getting my skill finished but I’m stumped since I’m not able to test it anymore in Alexa.

I was reviewing a similar thread (Works on Voiceflow, but doesn't on Alexa/Echo Dot) and someone mentioned “Alexa has some limits per “response” as above” - what are the limits? Could this be my problem? Is there anything else I should look out for?

I create a new skill from scratch, that was very basic with one speak block and I wasn’t able to invoke it in Alexa, but I could test in Voiceflow, I’m just wondering why that might be?

Thanks in advance for any insight!

Ah I think I figured it out prosody SSML tag was causing the issue. (I just removed this to fix my issue)

Also, i think I found a bug. When I added audio URL link to the speak block it wouldn’t work when I tested it in Alexa’s echo/ADC. But if I dragged and dropped the audio file, the audio file worked fine, and tested fine, so I just went with this method.

it’s not a bug. if you use audio by URL, that audio file must be formatted as Amazon says.

by uploading audio file with drag & drop, voiceflow automaticallly convert its format suitable for Alexa’s use.

Okay good to know!

Just to note: the same file play fine in the stream block but not the speak one. ( i think, it’s been a few days so not sure if I’m remembering correctly)

also this might be help.

1 Like

Speak Block: inserted audio link.
In alexa developer console test it goes wrong (There was a problem with the requested Skill response), it seems to write this wrong:

(adds slash and backslash).

it’s ok because

  • whole text is enclosed by double quotes. for using double quotes inside double quotes, escape(backslash) is needed.
  • Audio tag doesn’t need closing tag like “”. Instead of that, opening tag itself need “/”(slash) like “

One thing to add. There’s only a few case using audio files on Google Drive successfully, I think it’s because of Google Drive.

I recommend to use Amazon S3 or Dropbox.

even if you use audio file in Dropbox, default URL for sharing doesn’t work and you need change URL like this.



NOTICE: not sure if works 100%.

OK thanks, I will test.