SOLVED | API Call not returning any value

I needed help with getting value via API from Blynk to a variable in order to announce it on Alexa.

I’m making a Home Convenience Project, and needed to connect Blynk with Voiceflow. When I paste a URL with the following format on Chrome, it gives the desired output in 0 or 1:[my auth token]&v0[the desired Virtual Pin which gives the status of pin 0 or 1]

However, when make an API call using Voiceflow for the same, as well as create a variable to store value, nothing gets stored but API calls are successful when tested.

I would be very thankful to you if anyone can help me out with guidance or resources for the same.

The value will be stored in the variable, you might see the variable valve empty I guess because the response is not in json format, but anyway the value will be stored correctly.

1 Like
  1. The API call is supposed to be GET but on using GET I get this error:
  1. Now even when I use POST and test is successful, the program flow goes to the Failed block, and when I test a speak block with variable {status} name, it speaks out variable name.

@John93 I wanted to know what exactly have I missed. Because on pasting in chrome I successfully get the status of ‘Virtual Pin V0’ in 0 or 1. But this is the problem I’m facing on Voiceflow. I would really appreciate your help considering the deadline is approaching :slight_smile:

I am not getting any object paths as a test result, nor have I pasted any Header Assignments.

Can you show me how did you configure the API block please ?


Blynk does not support post method, you should use get method instead.

I’ve tried that but it shows the error I posted above

This is the error I get when I use GET method

Can you send me the full url you’re using so I can investigate ?
Don’t worry about The auth token, you can change it later.


This is the link I’m using to get the value:

And I’m using this one to send API call ‘1’ to turn On an LED connected to my ESP8266. This one is working:

Alright, I’ll check.


Both works fine.

I changed path from ‘response.0’ to ‘response’ and even mine works fine now.

Thank you so much @John93 :slight_smile: I really appreciate your help

1 Like

If you need any help, feel free to ask.

Have a great day.

1 Like


I tried everything but I cannot get the GET call to work. I always get “invalid token”. The call works fine via browser or postman. I have the same setup on the voiceflow api call as the picture above.

What could I be missing?
Thank you,

@Mehul , is that still working for you?