Speak interruption

Hi everyone!
I’m trying to create a skill to open a web page on Echo Show 5 and I’m using APL Website Demo found on Airtable - Voiceflow Community Marketplace.

When I say the command, Alexa opens the web page correctly but if I use a Speak Block to say “I’m opening the web page” the voice is interrupted before it finish the sentence.

I tried to put the Speak Block before and after the Display Block, set a sentence pause using the “Add Effect” option and insert an empty Speak Block between the sentence and the Display Block, but still, when opening Silk, the voice is interrupted and does not end the sentence.

How can I get Alexa to finish the sentence and then open the web page?

Thanks!

There is a trick to delay the command on APL. First set the link in the URL section. Second, APL text which is what’s to be displayed and third then finally adding a manual delay (ie. 3 seconds or 3000 milliseconds), as seen below, hitting the text before opening the webpage:

Another scrappy option, instead of using a Speak Step + the APL, you could also embed Text-to-Speech within the APL itself.

We’ll also update this demo on the marketplace, incorporating your feedback!

hello tashim!
Sorry for the delay in my answer but I have not received any email of yours from the voiceflow forum :expressionless:

Anyway, thank you very much for your help, but if I change the APL Website Demo JSON Datasource my skill won’t work properly.
Alexa opens Silk but not the website I want and the voice is still interrupted.

I see you are using another JSON named “apl-webopen” while mine is named “apl_website”. Are we using different versions?

My Datasource code is:

{
	"update": {
		"type": "object",
		"objectId": "updateTemplate",
		"website": {
			"url": "{websiteURL}"
		},
		"updateText": {
			"text": "{mytext}"
		}
	}
}