Unable to get some commands in Blynk API to work

Specifically, I can’t obtain application response to

    GET http://blynk-cloud.com/XXXXXYYYYZZZZ/update/V6?value=0

although this URL works properly if sent from my browser.

I do get valid response when I read Virtual pin 6 with

     GET http://blynk-cloud.com/XXXXXYYYYZZZZ/get/V6

have never used blynk, so this is just my guess.

I guess API step expects ‘application/json’ response, but ‘write pin value via GET’ API seems return ‘plain/text’ response.

https://blynkapi.docs.apiary.io/#reference/0/write-pin-value-via-get/write-pin-value-via-get

how about trying ‘write pin value via PUT’ API, which returns ‘application/json’ response?

https://blynkapi.docs.apiary.io/#reference/0/write-pin-value-via-put/write-pin-value-via-put

Thanks for the suggestion, but when I test the response I get the same error message as with the other API: “src property must be a valid json response”

I’m not sure how to troubleshoot this…totally confused !

There appears to be no header with these commands. Does voiceflow API integration require a header???

it says that API does not return correct JSON formatted response.

checked that document again and I found I misread. ‘write pin value via PUT’ requires JSON request but it response is ‘text/plain’, which Voiceflow does not accept. also, almost all Blynk API other than ‘get project’ and ‘get pin value’ will return ‘text/plain’ unfortunately.

Well, thanks for looking into that. Bummer, sounds like I’m not going to be able to use Voiceflow to accomplish what I want unless you know of a work around.

Quick update on this after having solved the issue for @chazbot

The update call needs the PUT method to work.

1 Like

http://188.166.206.43/xxxxxxxxxauth token xxxxxxxxxxxxx/update/pin?value=1

application/json

GET method

this is working

Hi…The hubs sends the auth token in an encoded message not uncovering the authtoken

Initially I was utilizing Blynk.configure(auth) and afterward Blynk associate this worked extraordinary in Blynk 1.0. Subsequent to addressing Pavel he proposed HTTPS API with Blynk 2.0 would be better. I can’t track down a functioning model and don’t have any desire to mess with him for it.

Blynk.virtualwrite will not work if the hub can’t interface with its extraordinary auth token.

The message gets shipped off the passage from the hub. The passage shakes hands and sends the hubs sensor information to Blynk.cloud

Hi,

It seems Blynk API changed a bit, and now it is like the following:
https://blynk.cloud/external/api/update?token=xpto&v2=0

And I can’t call it via voiceflow, it gives me an invalid token response.
although I can call it via browser or via postman with no issues.

Any ideas?
Thank you,
Tiago